Skip to main content

Hướng dẫn cấu hình VLANs, trunking và VLANs routing trên GNS 3

13,December 2016
Hướng dẫn cấu hình VLANs trunking và VLANs routing trên GNS3

Trước khi vào bài lab cấu hình VLANs trên Switch . Các bạn có thể xem qua bài viết Các khái niệm cơ bản về mạng và các thiết bị, chức năng của chúng để hiểu về collision domain và broadcast domain, cũng như cách cài đặt và cấu hình giả lập routers, switch layer 2, switch layer 3 trên GNS3 

I. Lý Thuyết 

a. VLANs là gì ?

+ VLANs ( Virtual Local Area Networks ) điều này có nghĩa bạn có thể  tạo ra những mạng LAN ảo ( một nhóm logic ) và nhón các thiết bị mạng như máy tính, server, switches, etc vào mạng LAN ảo bạn vừa định nghĩa 

b. Lợi ích khi sử dụng VLANs 

+ VLAN cho phép người quản trị mạng tổ chức mạng theo logic chứ không theo vật lý nhờ đó mà nó có những lợi ích sau

  • Broadcast control: giúp kiểm soát các gói tin broadcast ở các thiết bị layer 2 và tạo vùng colision domains dựa trên vùng mạng ảo (VLANs)
  • Security :  Một trong những vấn đề đối với mạng LAN chia sẻ đường truyền chung là chúng dễ dàng bị xâm nhập. Bằng cách gắn dây mạng vào một cổng, một người thâm nhập có thể truy cập được tất cả các thông tin được truyền trên nhánh mạng. Nhánh mạng càng lớn thì mức độ bị truy cập thông tin càng cao. VLANs giúp chia nhỏ vùng mạng giúp kiểm soát dữ liệu an toàn hơn. Ví dụ chúng ta thiết lập VLAN ( Accounting ) cho phòng kế toán và VLAN ( Sales ) cho phòng bán hàng, lúc này nhân viên của phòng kế toán sẽ không thể truy cập dữ liệu của phòng bán hàng  
  • Flexibility: dễ dàng trong việc thêm, xóa và thay đổi vị trí người sử dụng mạng một cách linh hoạt.

c. VTP là gì ?

VTP viết tắt của từ VLAN Trunking Protocol là phuơng thức độc quyền của Cisco hoạt động ở tầng 2. VTP giúp cho việc cấu hình VLAN luôn đồng nhất khi thêm , xóa , sửa thông tin về VLAN trong một hệ thống mạng .Với VTP , bạn phải cấu hình VLAN ban đầu trên một switch duy nhất ( đóng vai trò là VTP Server ) sẽ quảng bá bất kỳ Revison VLAN ( khi ta xóa,sữa,hoặc tạo thì số revision sẽ tăng lên 1 đơn vị ) , để các switch khác ( đóng vai trò VTP Client) nhận được cập nhật này thì phải có chung miền VTP hay còn gọi là VTP domain (nếu ta đặt VTP domain khác nhau thì các switch sẽ không liên kết với nhau ) . Các thông tin này sẽ được gửi đến một địa chỉ quảng bá ( multicast ) có địa chỉ MAC ( 01-00-0C-CC- CC-CC ) duy nhất mà các thiết bị Cisco tham gia vào VTP. Khi switch ở chế độ VTP mode Transparent , sẽ không quảng bá cấu hình VLAN của chính nó và cũng không đồng bộ dữ liệu VLANs của nó với thông tin VLANs quảng bá mà nó nhận được trong VTP domain.  switch ở VTP mode Transparent sẽ chuyển tiếp thông tin quảng bá VTP nhận được ra cổng trunk của nó .

d. Etherchannel là gì ?

Etherchanel là gì

+ Khi đường truyền giữa các thiết bị router hay switch sử dụng cổng Fast-Ethernet (FE) trở lên quá tải chúng ta phải nâng cấp đường truyền sử dụng GigaEthernet(GE), 10 GigaEthernet(10GE) để tăng tốc độ các link bằng các module và dây dẫn. Việc nâng cấp này rất tốn kém và cũng không cấn thiết. Giải pháp đưa ra chính là sư dụng công nghệ EtherChanel của cisco. Công nghệ EtherChannel có thể bó từ 2 đến 8 link FE, GE, 10GE thành 1 link logical. Khi đó, switch đối xử các port thuộc EtherChannel như 1 port duy nhất. 

+ Switch hoặc thiết bị ở 2 đầu EtherChannel phải hiểu và sử dụng công nghệ EtherChannel để đảm bảo hoạt động đúng và chống loop. Nếu chỉ có 1 đầu sử dụng EtherChannel, còn đầu bên kia không sử dụng thì có thể gây ra loop.

+ Traffic không phải lúc nào cũng được phân bố đồng đều qua các đường link thuộc EtherChannel, mà nó phụ thuộc vào phương pháp load balancing mà switch sử dụng và mẫu traffic trong mạng. Nếu một trong các link thuộc EtherChannel bị down thì traffic sẽ tự động được chuyển sang link khác trong channel chỉ trong vòng vài miliseconds . Khi link up trở lại thì traffic được phân bố lại như cũ.

II. Mô hình bài lab

Bài lab được thực hiện trên GNS3 với 4 switch trong switch L3-SW-1 và L3-SW-2 được kết nối với nhau và sử dụng etherchanel port. L3-SW1 đóng vai trò là VTP server, các switch con lại đóng vai trò VTP client. VLANs sẽ được tạo trên switch L3-SW1 ( vtp server ) sau đó sẽ update xuống các switch còn lại ( vtp client ) 

III. Cấu hình

Bước 1. Cấu hình VTP cho các switch 

+ Cấu hình VTP mode server và domain cisco trên switch L3-SW1

L3-SW1(config)#hostname L3-SW1
L3-SW1(config)#vtp mode server
L3-SW1(config)#vtp domain cisco
L3-SW1(config)#vtp password cisco
L3-SW1(config)#vtp pruning

+ Cấu hình VTP mode client trên switch L2-SW1 và L2-SW2 và L3-SW2

L2-SW1(config)#hostname L2-SW1
L2-SW1(config)#vtp mode client
L2-SW1(config)#vtp domain cisco
L2-SW1(config)#vtp password cisco

Switch L2-SW2

L2-SW2(config)#hostname L2-SW2
L2-SW2(config)#vtp mode client
L2-SW2(config)#vtp domain cisco
L2-SW2(config)#vtp password cisco

Switch L3-SW2

L3-SW2(config)#hostname L3-SW2
L3-SW2(config)#vtp mode client
L3-SW2(config)#vtp domain cisco
L3-SW2(config)#vtp password cisco

Bước 2: Cấu hình VLAN trên VTP server ( L3-SW1 )

L3-SW1#config t
L3-SW1(config)#vlan 10
L3-SW1(config-vlan)#name HR
L3-SW1(config)#vlan 20
L3-SW1(config-vlan)#name ADMIN
L3-SW1(config)#vlan 30
L3-SW1(config-vlan)#name IT

+ Kiển tra cấu hình vlan trên VTP mode Server ( L3-SW1 ) và VTP mode client ( L2-SW1 )

L3-SW1#show vlan brief
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Gi0/2, Gi0/3, Gi1/0, Gi1/1
                                                Gi1/2, Gi1/3, Gi2/0, Gi2/1
                                                Gi2/2, Gi2/3, Gi3/0, Gi3/1
                                                Gi3/2, Gi3/3
10   HR                               active
20   IT                               active
30   ADMIN                            active
1002 fddi-default                     act/unsup
1003 trcrf-default                    act/unsup
1004 fddinet-default                  act/unsup
1005 trbrf-default                    act/unsup
L2-SW1#show vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Gi0/1, Gi0/2, Gi0/3, Gi1/0
                                                Gi1/1, Gi1/2, Gi1/3, Gi2/0
                                                Gi2/1, Gi2/2, Gi2/3, Gi3/0
                                                Gi3/1, Gi3/2, Gi3/3
10   HR                               active
20   IT                               active
30   ADMIN                            active
100  VLAN100                          active
200  VLAN0200                         active
300  VLAN0300                         active
1002 fddi-default                     act/unsup
1003 trcrf-default                    act/unsup
1004 fddinet-default                  act/unsup
1005 trbrf-default                    act/unsup

Bước 3: Cấu hình trunk port trên các switch 

Switch L2-SW1

L2-SW1(config)#interface range G0/0,G0/3
L2-SW1(config-if-range)#switchport trunk encapsulation dot1q
L2-SW1(config-if-range)#switchport mode trunk
L2-SW1(config-if-range)#switchport trunk allowed vlan 10,20,30

Switch L2-SW2

L2-SW2(config)#interface range G0/0,G0/3
L2-SW2(config-if-range)#switchport trunk encapsulation dot1q
L2-SW2(config-if-range)#switchport mode trunk
L2-SW2(config-if-range)#switchport trunk allowed vlan 10,20,30

Switch L3-SW1

+ Cấu hình etherchannel 

L3-SW1(config)#interface range G0/1 - 2
L3-SW1(config-if-range)#channel-protocol lacp
L3-SW1(config-if-range)#channel-group 1 mode active
Creating a port-channel interface Port-channel 1

+ Kiểm tra cấu hình etherchannel

L3-SW1#show etherchannel summary

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         LACP      Gi0/1(P)    Gi0/2(P)

L3-SW1#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0     unassigned      YES unset  up                    up
GigabitEthernet0/1     unassigned      YES unset  up                    up
GigabitEthernet0/2     unassigned      YES unset  up                    up
Port-channel1             unassigned      YES unset  up                    up

L3-SW1#show interface Po 1
Port-channel1 is up, line protocol is up (connected)
  Hardware is GigabitEthernet, address is 00d3.84dc.da05 (bia 00d3.84dc.da05)
  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
 

+ Cấu hình trunking 

L3-SW1(config)#interface range G0/0, G0/3, G0/1-2, Po1
L3-SW1(config-if-range)#switchport trunk encapsulation dot1q
L3-SW1(config-if-range)#switchport mode trunk
L3-SW1(config-if-range)#switchport trunk allowed vlan 10,20,30
L3-SW1(config-if-range)#no shut

Swtich L3-SW2

+ Cấu hình etherchannel 

L2-SW2(config)#interface range G0/1 - 2
L2-SW2(config-if-range)#channel-protocol lacp
L2-SW2(config-if-range)#channel-group 1 mode passive
Creating a port-channel interface Port-channel 1

+ Kiểm tra etherchannel

L2-SW2#show etherchannel summary

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         LACP      Gi0/1(P)    Gi0/2(P)

L2-SW2#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0     unassigned      YES unset  up                    up
GigabitEthernet0/1     unassigned      YES unset  up                    up
GigabitEthernet0/2     unassigned      YES unset  up                    up
Port-channel1             unassigned      YES unset  up                    up

L2-SW2#show interface Po 1
Port-channel1 is up, line protocol is up (connected)
  Hardware is GigabitEthernet, address is 00d3.84a7.0405 (bia 00d3.84a7.0405)
  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
 

+ Cấu hình trunk port 

L3-SW2(config-if-range)#int range G0/0,G0/3, G0/1-2, Po1
L3-SW2(config-if-range)#switchport trunk encapsulation dot1q
L3-SW2(config-if-range)#switchport mode trunk
L3-SW2(config-if-range)#switchport trunk allowed vlan 10,20,30
L3-SW2(config-if-range)#no shut

Bước 4:  Cấu hình VLANs routing và switch access vlan trên switch L3-SW1, L2-SW1 và L2-SW2

L3-SW1(config)#int vlan 10
L3-SW1(config-if)#ip add 192.168.10.1 255.255.255.0
L3-SW1(config)#int vlan 20
L3-SW1(config-if)#ip add 192.168.20.1 255.255.255.0
L3-SW1(config)#int vlan 30
ip add 192.168.30.1 255.255.255.0

L3-SW1(config)#ip routing

+ Cấu hình Switch access vlan interfaces trên L2-SW1 & L2-SW2

L2-SW1(config)#int G0/1
L2-SW1(config-if)#switchport mode access
L2-SW1(config-if)#switchport access vlan 10
L2-SW1(config)#int G0/2
L2-SW1(config-if)#switchport mode access
L2-SW1(config-if)#switchport access vlan 20

 

L2-SW2(config)#int G0/1
L2-SW2(config-if)#switchport mode access
L2-SW2(config-if)#switchport access vlan 10
L2-SW2(config)#int G0/2
L2-SW2(config-if)#switchport mode access
L2-SW2(config-if)#switchport access vlan 20

Bước 5: Cấu hình địa chỉ ip address cho các PC

PC1> ip 192.168.10.10/24 192.168.10.1
Checking for duplicate address...
PC1 : 192.168.10.10 255.255.255.0 gateway 192.168.10.1
PC2> ip 192.168.20.10/24 192.168.20.1
Checking for duplicate address...
PC1 : 192.168.20.10 255.255.255.0 gateway 192.168.20.1
PC3> ip 192.168.10.20/24 192.168.10.1
Checking for duplicate address...
PC1 : 192.168.10.20 255.255.255.0 gateway 192.168.10.1
PC4> ip 192.168.20.20/24 192.168.20.1
Checking for duplicate address...
PC1 : 192.168.20.20 255.255.255.0 gateway 192.168.20.1

Bước 6: Kiểm tra kết quả từ PC1 ta thấy ping giữa VLAN 10 và VLAN 20 thành công -> VLAN routing successful

PC1> ping 192.168.10.1
84 bytes from 192.168.10.1 icmp_seq=1 ttl=255 time=34.002 ms
84 bytes from 192.168.10.1 icmp_seq=2 ttl=255 time=53.003 ms
84 bytes from 192.168.10.1 icmp_seq=3 ttl=255 time=18.001 ms
84 bytes from 192.168.10.1 icmp_seq=4 ttl=255 time=9.001 ms

PC1> ping 192.168.10.20
84 bytes from 192.168.10.20 icmp_seq=1 ttl=64 time=90.005 ms
84 bytes from 192.168.10.20 icmp_seq=2 ttl=64 time=59.003 ms
84 bytes from 192.168.10.20 icmp_seq=3 ttl=64 time=91.005 ms
84 bytes from 192.168.10.20 icmp_seq=4 ttl=64 time=84.005 ms

PC1> ping 192.168.20.1
84 bytes from 192.168.20.1 icmp_seq=1 ttl=255 time=23.001 ms
84 bytes from 192.168.20.1 icmp_seq=2 ttl=255 time=23.001 ms
84 bytes from 192.168.20.1 icmp_seq=3 ttl=255 time=96.006 ms
84 bytes from 192.168.20.1 icmp_seq=4 ttl=255 time=40.002 ms

PC1> ping 192.168.20.20
84 bytes from 192.168.20.20 icmp_seq=2 ttl=63 time=101.005 ms
84 bytes from 192.168.20.20 icmp_seq=3 ttl=63 time=107.006 ms
84 bytes from 192.168.20.20 icmp_seq=4 ttl=63 time=146.008 ms
84 bytes from 192.168.20.20 icmp_seq=5 ttl=63 time=112.006 ms

IV. Video hướng dẫn