Skip to main content

Hướng dẫn cấu hình HSRP trên GNS3

18,December 2016
Hướng dẫn cấu hình HSRP cho VLANs

Hot Standby Router Protocol (HSRP) là 1 giao thức của Cisco để tạo ra những gateway dự phòng (Redundancy) cho mạng nội bộ . HSRP tạo ra 1 địa chỉ gateway với MAC và IP address ảo được chia sẻ giữa 2 hay nhiều routers. Sẽ có một router đảm nhận vai trò chính (active) sẽ nắm giữ địa chỉ gateway ảo và chịu trách nhiệm xử lý các gói tin đi ra mạng ngoài và một router khác làm backup (standby). Khi router (active) bị down , router (standby) sẽ thế chỗ và giữ địa chỉ gateway ảo. Lúc này router(standby) sẽ trở thành active và chịu trách nhiệm xử lý các gói tin đi ra ngoài qua địa chỉ gateway ảo

+ Active Router 

cấu hình HSRP gateway redudancy active

+ Standby Router

cấu hình HSRP gateway redudancy active

1. Các đặt tính của HSRP

+ Gói tin Hello sẽ được gửi sau mỗi 3 giây. Nếu router standby không nhận được gói tin hello sau 10 giây nó sẽ mặc định router (active) bị down và sẽ chuyển từ trạng thái standby thành active và giữ địa chỉ gateway ảo để xử lý các gói tin đi ra ngoài mạng 

+ HSRP là hệ thống active - standby hay còn gọi là fail-over không phải hệ thống loadbalancing. Nhưng chúng ta có thể cấu hình loadbalancing giữa các VLANs ( Ví dụ VLAN 10 cho chạy qua router 1, VLAN 20 cho chạy qua router 2 ) 

+ Địa chỉ MAC address được sinh ra khi chúng ta tạo HSRP standby group 

+ HSRP active router và standby router gửi  gói tin hello đến địa chỉ multicast 224.0.0.2, dùng giao thức UDP port  1985 để duy trì thông tin

2. Câu lệnh cấu hình HSRP

Câu lệnh Chú thích
Router(config)#interface <type number>
Router(config-if)#standby <0-255> ip
Enable HSRP với group number trên interface mode
Router(config-if)#standby <0-255> ip <a.b.c.d> Cấu hình HSRP standby group với Virtual IP address
Router(config-if)#standby <0-255> preempt  Cấu hình pre-emption để router tự động chuyển sang mode active khi có priority lơn hơn
Router(config-if)#standby <0-255> priority <0-255>  Cấu hình HSRP group priority
Router(config-if)#standby <0-255> track <interface type number> <decrement value>  Giám sát cổng của router (active) sử dụng để đi ra ngoài mạng, Nếu cổng này down sẽ trừ HSRP priorty của  router này giá trị khai báo
Router(config-if)#standby <0-255> timers msec <hello-value> 
Router(config-if)#standby <0-255> timers msec <holdtime-value>
Cấu hình giá trị hello timer và hold timer cho HSRP
Router(config-if)#no standby <0-255> timers  Reset giá trị hello timer và hold timer về default ( 3 và 8 giây )
Router(config-if)#standby <0-255> authentication <value> 
Router(config-if)#standby <0-255> authentication md5 key-string 0|7 <value> 

Cấu hình chứng thực để router có thể nhận được các gói tin HSRP từ router khác trong HSRP group

  • "0" giá trị key sẽ không mã hóa
  • "7" giá trị key sẽ được mã hóa
Router#show standby  Trả về trang thái cấu hình HSRP 
Router#debug standby Sử dụng câu lệnh để debug xem router có nhận ra các routers khác trong HSRP group không, và xem quá trình trao đổi các gói tin HSRP

3. Mô hình bài lab

cấu hình HSRP trên gns3

+ HSRP sẽ được cấu hình trên 2 switch layer 3 là L3-SW1 và L3-SW2 với 

  • VLAN 10: L3-SW1 sẽ là HSRP active và L3-SW2 sẽ là HSRP standby với gateway ảo có IP: 192.168.10.254/24 để đi ra ngoài internet
  • VLAN 20: L3-SW2 sẽ là HSRP active và L3-SW1 sẽ là HSRP standby với gateway ảo có IP: 192.168.20.254/24 để đi ra ngoài internet

+ Bài lab được thực hiện nối tiếp bài lab "Cấu hình per-vlan spanning tree trên GNS3". Hoặc các bạn có thể "cài đặt GNS3 và setup switch layer 3" sau đó download file lab GNS3 dựng sẵn từ địa chỉ mediafire http://www.mediafire.com/file/f7wbk1aso10makc/HSRP-GNS3.zip  để thực hiện bài lab này

+ Để cấu hình HSRP trên GNS3 chúng ta phải giả lập switch với file IOS C3725 và giả lập router với file IOS C7200 để cấu hình IP SLA. các bạn download tại địa chỉ http://www.mediafire.com/file/4oca7byw19do1bw/IOS-GNS3.rar

Để giả lập Router bằng C7200 

+ Các bạn xem lại bài viết hướng dẫn sử dụng GNS3 và làm tương tự với router C7200 và 1 điều chú ý khi đến bước chọn slot 0 = C7200-IO-2FE như hình vẽ 

Cấu hình giả lập router switch layer 3 trên gns3

Để giả lập switch Layer 3 bằng C3725 

+ Open GNS3 -> Chon Edit -> Preferences -> IOS routers (chọn New -> New Image -> Browse tới file IOS router download ở trên ) -> chọn Next

Cấu hình giả lập router switch layer 3 trên gns3

 

Cấu hình giả lập router switch layer 3 trên gns3

 

Cấu hình giả lập router switch layer 3 trên gns3

 

Cấu hình giả lập router switch layer 3 trên gns3

 

Cấu hình giả lập router switch layer 3 trên gns3

 

Cấu hình giả lập router switch layer 3 trên gns3

 

Cấu hình giả lập router switch layer 3 trên gns3

 

    4. Cấu hình

    a. Ôn lại kiếm thức của các bài trước chúng ta cùng cấu hình VTP, VLANs, Trungking, VLAN routing cho các switch 

    + Trên L3-SW1

    L3-SW1#vlan database
    L3-SW1(vlan)#vtp server
    L3-SW1(vlan)#vtp domain cisco
    L3-SW1(vlan)#vtp password cisco
    L3-SW1(vlan)#vlan 10 name HR
    L3-SW1(vlan)#vlan 20 name IT
    L3-SW1(vlan)#exit
    L3-SW1#show vlan-switch brief
    
    L3-SW1(config)#spanning-tree vlan 10 root primary
    L3-SW1(config)#spanning-tree vlan 20 root secondary
    
    L3-SW1(config)#interface range fa1/0 - 2
    L3-SW1(config-if-range)#switchport trunk encapsulation dot1q
    L3-SW1(config-if-range)#switchport mode trunk
    L3-SW1(config-if-range)#switchport trunk allowed vlan 10,20
    L3-SW1(config-if-range)#no shut
    
    L3-SW1(config)#int fa0/0    //Vì giả lập Switch Layer3 bằng IOS của router nên chỉ 2 interface Fa0/0, Fa0/1 có thể set ip address 
    L3-SW1(config-if)#ip add 11.11.11.2 255.255.255.252
    L3-SW1(config-if)#no shut
    
    L3-SW1(config)#ip route 0.0.0.0 0.0.0.0 11.11.11.1
    
    
    

    + Trên L3-SW2

    L3-SW2#vlan database
    L3-SW2(vlan)#vtp client
    L3-SW2(vlan)#vtp domain cisco
    L3-SW2(vlan)#vtp password cisco
    L3-SW2(vlan)#exit
    L3-SW2#show vtp status
    
    L3-SW2(config)#spanning-tree vlan 20 root primary
    L3-SW2(config)#spanning-tree vlan 10 root secondary
    
    L3-SW2(config)#interface range Fa1/0 - 2
    L3-SW2(config-if-range)#switchport trunk encapsulation dot1q
    L3-SW2(config-if-range)#switchport mode trunk
    L3-SW2(config-if-range)#switchport trunk allowed vlan 10,20
    L3-SW2#show vlan-switch br
    
    L3-SW2(config)#interface Fa0/1  //Vì giả lập Switch Layer3 bằng IOS của router nên chỉ 2 interface Fa0/0, Fa0/1 có thể set ip address 
    L3-SW2(config-if)#ip address 12.12.12.2 255.255.255.0
    L3-SW2(config-if)#no shut
    
    L3-SW2(config)#ip route 0.0.0.0 0.0.0.0 12.12.12.1
    

    + Trên L2-SW1

    L2-SW1#vlan database
    L2-SW1(vlan)#vtp client
    L2-SW1(vlan)#vtp domain cisco
    L2-SW1(vlan)#vtp password cisco
    
    L2-SW1(config)#interface range Fa1/0 - 1
    L2-SW1(config-if-range)#switchport trunk encapsulation dot1q
    L2-SW1(config-if-range)#switchport mode trunk
    L2-SW1(config-if-range)#switchport trunk allowed vlan 10,20
    L2-SW1#show vlan-switch brief
    L2-SW1#show interfaces trunk
    
    L2-SW1(config)#interface Fa1/2
    L2-SW1(config-if)#switchport mode access
    L2-SW1(config-if)#switchport access vlan 10
    L2-SW1(config)#interface Fa1/3
    L2-SW1(config-if)#switchport mode access
    L2-SW1(config-if)#switchport access vlan 20

    + Trên L2-SW2

    L2-SW2#vlan database
    L2-SW2(vlan)#vtp client
    L2-SW2(vlan)#vtp domain cisco
    L2-SW2(vlan)#vtp password cisco
    
    L2-SW2(config)#interface range Fa1/0 - 1
    L2-SW2(config-if-range)#switchport trunk encapsulation dot1q
    L2-SW2(config-if-range)#switchport mode trunk
    L2-SW2(config-if-range)#switchport trunk allowed vlan 10,20
    L2-SW2#show interfaces trunk
    L2-SW2#show vlan-switch brief
    
    L2-SW2(config)#interface Fa1/2
    L2-SW2(config-if)#switchport mode access
    L2-SW2(config-if)#switchport access vlan 10
    L2-SW2(config)#interface Fa1/3
    L2-SW2(config-if)#switchport mode access
    L2-SW2(config-if)#switchport access vlan 20
    

    + Trên router R1

    R1(config)#interface Fa0/0
    R1(config-if)#ip address 11.11.11.1 255.255.255.252
    R1(config-if)#no shut
    R1(config)#interface Fa0/1
    R1(config-if)#ip address 12.12.12.1 255.255.255.252
    R1(config-if)#no shut
    R1(config)#interface loopback 1
    R1(config-if)#ip address 1.1.1.1 255.255.255.255
    

    Cấu hình ip routing với route tracking sử dụng  IP Service Level Agreements (SLAs)

    + Trên router R1 cấu hình IP SLA tracking 11 tới interface Fa0/0 của L3-SW1 có địa chỉ 11.11.11.2

    R1(config)#ip sla 11
    R1(config-ip-sla)#icmp-echo 11.11.11.2
    R1(config-ip-sla-echo)#frequency 5
    R1(config-ip-sla-echo)#timeout 5000
    R1(config-ip-sla-echo)#threshold 100
    R1(config)#ip sla schedule 11 life forever start-time now
    
    R1(config)#track 11 ip sla 11 reachability

    + Trên router R1 cấu hình IP SLA tracking 12 tới interface Fa0/1 của L3-SW2 có địa chỉ 12.12.12.2

    R1(config)#ip sla 12
    R1(config-ip-sla)#icmp-echo 12.12.12.2
    R1(config-ip-sla-echo)#frequency 5
    R1(config-ip-sla-echo)#timeout 5000
    R1(config-ip-sla-echo)#threshold 100
    R1(config)#ip sla schedule 12 life forever start-time now
    
    R1(config)#track 12 ip sla 12 reachability

    + Cấu hình static routing với IP SLAs tracking ( Từ R1 nếu tracking 11 nhận thấy không ping được tới địa chỉ 11.11.11.2 toàn bộ gói tin sẽ được đẩy qua fa0/1 tới địa chỉ 12.12.12.2 và ngược lại  với tracking 12) 

    R1(config)#ip route 0.0.0.0 0.0.0.0 11.11.11.2 track 11 
    R1(config)#ip route 0.0.0.0 0.0.0.0 12.12.12.2 track 12

    b. Cấu hình HSRP

    + Yêu cầu:

    • VLAN 10 trên L3-SW1 sẽ là HSRP active và  trên L3-SW2 sẽ là HSRP standby với gateway ảo có IP: 192.168.10.254/24 để đi ra ngoài internet
    • VLAN 20 trên L3-SW1 sẽ là HSRP standby và  trên L3-SW2 sẽ là HSRP active với gateway ảo có IP: 192.168.20.254/24 để đi ra ngoài internet

    + Trên L3-SW1

    Cấu hình địa chỉ ip address cho VLAN 10, 20

    L3-SW1(config)#interface vlan 10
    L3-SW1(config-if)#ip add 192.168.10.1 255.255.255.0
    L3-SW1(config-if)#no shut
    L3-SW1(config)#interface vlan 20
    L3-SW1(config-if)#ip add 192.168.20.1 255.255.255.0
    L3-SW1(config-if)#no shut
    L3-SW1(config)#ip routing
    L3-SW1#show ip interface brief

    Cấu hình HSRP cho VLAN 10 có vai trò "Active"

    L3-SW1(config)#track 10 interface fastEthernet 0/0 line-protocol //Định nghĩa track 20 monitor interface Fa0/0
    L3-SW1(config)#interface vlan 10
    L3-SW1(config-if)#standby 10 ip 192.168.10.254
    L3-SW1(config-if)#standby 10 priority 200 //default 100, higher is better
    L3-SW1(config-if)#standby 10 track 10 decrement 101 //priority sẽ bị trừ đi 101 nếu track 10 thấy Fa0/0 down
    L3-SW1(config-if)#standby 10 preempt
    

    Cấu hình HSRP cho VLAN 20 có vai trò "Standby"

    L3-SW1(config)#interface vlan 20
    L3-SW1(config-if)#standby 20 ip 192.168.20.254
    L3-SW1(config-if)#standby 20 preempt
    //default priority = 100, no need to config here

    + Trên L3-SW2 

    Cấu hình địa chỉ ip address cho VLAN 10, 20

    L3-SW2(config)#interface vlan 10
    L3-SW2(config-if)#ip address 192.168.10.2 255.255.255.0
    L3-SW2(config-if)#no shut
    L3-SW2(config)#interface vlan 20
    L3-SW2(config-if)#ip address 192.168.20.2 255.255.255.0
    L3-SW2(config-if)#no shut
    L3-SW2(config)#ip routing
    L3-SW2#show ip interface brief

    Cấu hình HSRP cho VLAN 10 có vai trò "Standby"

    L3-SW2(config)#interface vlan 10
    L3-SW2(config-if)#standby 10 ip 192.168.10.254
    L3-SW2(config-if)#standby 10 preempt

    Cấu hình HSRP cho VLAN 20 có vai trò "Active"

    L3-SW2(config)#track 20 interface fastEthernet 0/1 line-protocol  //Định nghĩa track 20 monitor interface Fa0/1
    L3-SW2(config)#interface vlan 20
    L3-SW2(config-if)#standby 20 ip 192.168.20.254
    L3-SW2(config-if)#standby 20 priority 200 //default=100, higher is better
    L3-SW1(config-if)#standby 20 track 20 decrement 101 //priority sẽ bị trừ đi 101 nếu track 20 thấy Fa0/1 down
    L3-SW2(config-if)#standby 20 preempt

     

    + Kiểm tra HSRP standby trên L3-SW1 và L3-SW2

    L3-SW1#show standby vlan 10

    Vlan10 - Group 10
      State is Active

        2 state changes, last state change 00:07:30
      Virtual IP address is 192.168.10.254
      Active virtual MAC address is 0000.0c07.ac0a

        Local virtual MAC address is 0000.0c07.ac0a (v1 default)
      Hello time 3 sec, hold time 10 sec
        Next hello sent in 2.236 secs
      Preemption enabled
      Active router is local
      Standby router is 192.168.10.2, priority 100 (expires in 7.988 sec)
      Priority 200 (configured 200)
      IP redundancy name is "hsrp-Vl10-10" (default)

    L3-SW1#show standby vlan 20

    Vlan20 - Group 20
      State is Standby

        4 state changes, last state change 00:01:14
      Virtual IP address is 192.168.20.254
      Active virtual MAC address is 0000.0c07.ac14

        Local virtual MAC address is 0000.0c07.ac14 (v1 default)
      Hello time 3 sec, hold time 10 sec
        Next hello sent in 0.560 secs
      Preemption enabled
      Active router is 192.168.20.2, priority 200 (expires in 9.516 sec)
      Standby router is local
      Priority 100 (default 100)
      IP redundancy name is "hsrp-Vl20-20" (default)

     

    L3-SW2#show standby vlan 10

    Vlan10 - Group 10
      State is Standby

        1 state change, last state change 00:02:25
      Virtual IP address is 192.168.10.254
      Active virtual MAC address is 0000.0c07.ac0a

        Local virtual MAC address is 0000.0c07.ac0a (v1 default)
      Hello time 3 sec, hold time 10 sec
        Next hello sent in 1.756 secs
      Preemption enabled
      Active router is 192.168.10.1, priority 200 (expires in 7.056 sec)
      Standby router is local
      Priority 100 (default 100)
      IP redundancy name is "hsrp-Vl10-10" (default)

    L3-SW2#show standby vlan 20
    

    Vlan20 - Group 20
      State is Active

        1 state change, last state change 00:03:01
      Virtual IP address is 192.168.20.254
      Active virtual MAC address is 0000.0c07.ac14

        Local virtual MAC address is 0000.0c07.ac14 (v1 default)
      Hello time 3 sec, hold time 10 sec
        Next hello sent in 1.888 secs
      Preemption enabled
      Active router is local
      Standby router is 192.168.20.1, priority 100 (expires in 9.972 sec)
      Priority 200 (configured 200)
      IP redundancy name is "hsrp-Vl20-20" (default)

    + Cấu hình địa chỉ ip address và default gateway cho các PC1 -> PC4

    PC1> ip 192.168.10.10/24 192.168.10.254
    PC2> ip 192.168.20.10/24 192.168.20.254
    PC3> ip 192.168.10.20/24 192.168.10.254
    PC4> ip 192.168.20.20/24 192.168.20.254

    + Từ PC1 và PC2 thực hiện lệnh ping tới địa chỉ loopback 1 với ip 1.1.1.1 của router R1 sau đó kiểm tra khẳ năng redudancy của HSRP bằng cách

    • Shutdown cổng Fa0/0 của L3-SW1 và đổi lại Fa0/1 của L3-SW2 

    • Tắt switch L3-SW1 và đổi lại với L3-SW2

     

    5. Video hướng dẫn